Cách Kết Nối Ipv6


*

IPv6 là gì

Lịch sử Thành lập và hoạt động của IPv6 (trường đoản cú viết tắt của Internet Protocol 6) tương đối lâu. Đó là vào thời điểm năm 1981, Lúc những máy vi tính phần đông chỉ có thể truy cập mạng internet phục vụ cho những tổ chức triển khai phân tích quân sự. Với môi trường thao tác làm việc 8 bit, kết phù hợp với không gian địa chỉ 32 bit vị phiên bản Internet Protocol 4 (viết tắt là IPv4) cung ứng có thể chấp nhận được kết nối tới 4 tỷ shop không giống nhau. 

Trải qua ngay sát 30 năm, sự phát triển của công nghệ đã sinh sản bước bứt phá, internet lâu dài trên khắp quả đât khiến cho con số tương tác đã được gần đến cả cực lớn. Đồng thời, nó còn dự báo có thể thừa giới hạn của IPv4. Về triết lý, ví như vượt nút è cổ thì tài năng kết nối internet sẽ không thể vận động được. Chính vấn đề đó vẫn tạo động lực thúc đẩy việc phân tích, cải tiến và phát triển giao thức bắt đầu, giúp hạn chế điểm yếu bên trên.

Bạn đang xem: Cách kết nối ipv6

Đầu trong thời hạn 1990, IETF phát triển một giao thức mới có tên gọi là IP. Next Generation (IPng). Và vào thời điểm năm 1998, giao thức này bằng lòng chuẩn hóa, được Tổng đơn vị Internet đến tên miền và số (viết tắt là ICANN) phê duyệt y, có thể chấp nhận được thực hiện trên rộng rãi trên toàn cầu. Giao thức được lấy tên IPv6 (RFC 1883).

IPv6 ra đời vẫn giải quyết và xử lý được rất nhiều tinh giảm tồn tại của IPv4 trong khối hệ thống mạng internet, tạo ra bước tiến nhảy đầm vọt của technology số.

Các điểm cải tiến của IPv6 đối với IPv4:

Không gian tàng trữ bự. IPv4 gồm không gian truy vấn 32 bit, tương đương 4 tỷ can dự. Còn IPv6 tất cả không khí là 128 bit, to hơn vội 4 lần so với IPv4. Độ bảo mật thông tin cao hơn. Khả năng định tuyến được tăng đột biến. Cấu hình được thiết kế theo phía dễ dàng hơn đối với IPv4.

Lợi ích của IPv6 connectivity

Các tiện ích nhưng IPv6 vẫn với đã đem về cho tất cả những người cần sử dụng kia là:

Cho phxay không khí liên quan lớn, góp bài toán cai quản không gian này trở đề xuất dễ ợt hơn. Quản trị tiện lợi rộng. Do IPv6 có công dụng auto cấu hình mà lại ko cần đến máy chủ DHCP.. Trong lúc đó, IPv4 bắt buộc DHCP để cấu hình. Định tuyến IPv6 được thiết kế phân cấp đề nghị cấu trúc xuất sắc. IPv6 cung cấp tốt hơn về Multicast. Việc thu xếp với định dạng header được thực hiện khoa học với về tối ưu giúp vấn đề bảo mật thông tin biết tin được đổi mới hơn. IPv6 cung cấp xuất sắc cho những sản phẩm cầm tay.

Cấu trúc hệ trọng IPv6

Cấu trúc của IPv6

Cấu trúc của một IPv6 tất cả 128 bit, được phân thành 8 nhóm. Trong số đó, mỗi team tất cả 16 bit với được phân loại bởi lốt “:”.

Một can hệ IPv6 được biểu lộ theo kết cấu sau:

FEDC:BA98:768A:0C98:FEBA:CB87:7678:1111:1080:0000:0000:0070:0000:0989:CB45:345F

Vì kết cấu vượt dài buộc phải người ta hay quăng quật số 0 nghỉ ngơi đầu từng team để rút ít gọn. Đối với team nào chỉ tất cả tuyệt nhất dãy số 0 thì nó sẽ được biểu diễn bằng dấu “::”

*

Cấu trúc của Address Prefixes

Address Prefixes bao gồm cấu tạo giống như IPv4 CIDR. Cách diễn đạt của chính nó là IPv6-address/ prefix-length. 

Trong đó:

- IPv6-address: Địa chỉ IPv6 với mức giá trị bất kỳ.

- Prefix-length: Số bit gần cạnh nhau trong prefix.

Ví dụ: Quy tắc màn biểu diễn của 56 bit prefix 200F00000000AB là

200F::AB00:0:0:0:0/56

200F:0:0:AB00::/56

Lưu ý: Với can dự IPv6, kí hiệu “::” chỉ được sử dụng độc nhất 1 lần vào một sự màn biểu diễn.

Các yếu tố của IPv6

Địa chỉ IPv6 có 3 thành phần: site prefix, subnet ID cùng interface ID. Trong đó:

Site prefix: Đây là thông số được gán với trang web trải qua ISP.. Do đó, toàn bộ máy tính ở thuộc địa điểm vẫn share với nhau bằng một site prefix. cũng có thể thấy, tính năng của site prefix là khi đã nhận ra mạng của người dùng với được cho phép truy cập trải qua internet thì nó đã tìm hiểu câu hỏi cần sử dụng phổ biến. Subnet ID: Đây là yếu tắc phía bên trong trang web. Nó được dùng làm diễn tả cấu tạo site của mạng. Vì cầm, một IPv6 subnet sẽ có được cấu trúc tương tự một nhánh mạng 1-1. Interface ID: Cấu trúc của nó tương tự ID trong IPv4. Các thông số đang thừa nhận dạng một host riêng. Interface ID có cấu hình tự động. 

Ví dụ: Địa chỉ IPv6 gồm cấu trúc: 2001:0f68:0000:0000:0000:0000:1986:69af bao gồm:

- Site prefix: 2001:0f68:0000

- Subnet ID: 0000

- Interface ID: 0000:0000:1986:69af
*

Phân các loại ảnh hưởng IPv6 connectivity

Có 3 một số loại cửa hàng IPv6:

Unicast: Một tác động Unicast được chỉ định và hướng dẫn riêng rẽ cho 1 cổng của node IPv6. lúc gồm một gói tin gửi mang đến can hệ Unicast, nó sẽ được mang lại cổng sẽ chỉ định và hướng dẫn bởi liên tưởng đó. Multicast: Đây là team các cổng IPv6. Khi một gói tin gửi mang đến liên hệ Multicast thì nó sẽ được toàn thể thành viên trong đội multicast cách xử trí. Anycast: Đây là liên tưởng ĐK đến các cổng (tức trên các node). lúc tất cả gói tin gửi mang lại cửa hàng Anycast, nó sẽ tiến hành đưa đến một cổng ngẫu nhiên, tuy vậy, đa phần là mang đến cổng sớm nhất.

Hướng dẫn biện pháp đặt thúc đẩy IPv6 đến win 7, 8, 10

Để đặt can dự Ipv6 đến win 7, 8, 10, chúng ta triển khai như sau:

Cách 1: Click vào hình tượng Window, chọn tiếp Run. Trong cửa sổ Run, nhập loại chữ ncpage authority.cpl. Bước 2: Bạn chọn thẻ mạng ao ước gán IPv6, tiếp đến lựa chọn tiếp Properties. Cách 3: Tiếp tục lựa chọn Internet Protocol Version 6 (TCP/IPv6), rồi lựa chọn Properties.
*
Bước 4: Quý Khách tiến hành điền các thông số kỹ thuật cực hiếm IPv6 ở trong nhà hỗ trợ (tham khảo hình bên dưới). 
*
Cách 5: Sử dụng câu lệnh ipconfig nghỉ ngơi cmd để tiến hành ping bình chọn công dụng IPv6. Bằng bí quyết, msinh hoạt cmd, gõ tiếp lệnh ipconfig. Hiện giờ, một cửa sổ hiển thị như hình sau.
*

Kế cho, thực hiện loại lệnh ping -6 ipv6.google.com để chất vấn IPv6:

*

Nếu hệ thống hiển thị hiệu quả trả lời tức là bạn vẫn thiết lập thành công xuất sắc thúc đẩy IPv6.

Hướng dẫn biện pháp thực hiện IPv6 - đặt can hệ IPv6 thông qua Remote UI

Các thao tác tiến hành đặt liên tưởng IPv6 bằng phương pháp áp dụng Remote UI được triển khai như sau:

Bước 1: Quý Khách khởi động Remote UI và đăng nhtràn vào khối hệ thống. Cách 2: Cliông chồng lựa chọn thỏng mục Setting/Registration sống cột mặt nên nhỏng hình sau.
*
Cách 3: Trong bảng hiện ra, cliông chồng chọn Network Setting, rồi lựa chọn tiếp TCP/ IPhường Settings.
*
Bước 4: Tại mục IPv6 Setting, chúng ta cliông xã lựa chọn Exit.
*
Cách 5: Lúc bấy giờ một bảng thoại xuất hiện. Quý khách hàng lựa chọn vỏ hộp chất vấn rồi thực hiện thông số kỹ thuật thiết đặt.
*
Bước 6: lúc sẽ hoàn chỉnh thiết đặt ngơi nghỉ bước 5, chúng ta clichồng OK để dứt thiết đặt IPv6.

Cấu hình IPv6 bên trên Router Cisco

Các bước thực hiện nlỗi sau:

Cách 1: Tiến hành cấu hình IPv4, giao thức OSPFv2 trên các Router Thename cùng Thename1. Đây là đông đảo tên router mang định cơ mà Hosting Việt đặt đến ví dụ minch họa sau để bạn dễ nắm bắt. Trong thực tiễn, chúng ta cũng có thể khắc tên tùy ý theo nhu yếu thực hiện.

- Thename: 

Cú pháp câu lệnh thực hiện:

Thename#config terminal

Thename(Config)#interface fastethernet 0/0

Thename(Config-if)#ip address 192.168.12.1 255.255.255.0

Thename(Config-if)#no shut

Thename(Config-if)#interface loopbaông chồng 0

Thename(Config-if)#ip address 1.1.1.1 255.255.255.255

Thename(Config-if)#no shut

Thename(Config-if)#interface fastethernet 0/1

Thename(Config-if)#no ip address

Thename(Config-if)#ipv6 enable

Thename(Config-if)#ipv6 address 2000::1/64

Thename(Config-if)#no shut

Thename(Config-if)#exit

Thename(Config)#router ospf 100

Thename(Config-router)#network 1.1.1.1 0.0.0.0 area 0

Thename(Config-router)#network 192.168.12.0 0.0.0.255 area 0

- Trên ISP:

Cú pháp câu lệnh:

ISP#config terminal

ISP(Config)#interface fastethernet 0/0

ISP(Config-if)#ip address 192.168.12.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#interface fastethernet 0/1

ISP(Config-if)#ip address 192.168.23.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#exitISP(Config)#router ospf 100

ISP(Config-router)#network 192.168.12.0 0.0.0.255 area 0

ISP(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Hình sau là bảng định tuyến đường IPv4 trên Thename.

Xem thêm: Hướng Dẫn Cách Nấu Súp Thịt Bằm, Cách Nấu Súp Thịt Bằm Ngon Bổ Dưỡng

*

- Thename1

Cú pháp câu lệnh:

Thename1#config terminal

Thename1(Config)#interface fastethernet 0/0

Thename1(Config-if)#ip address 192.168.23.3 255.255.255.0

Thename1(Config-if)#no shut

Thename1(Config-if)#exit

Thename1(Config)#router ospf 100

Thename1(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Dưới đấy là bảng định tuyến đường IPv4 trên Thename1.

*

Lúc bấy giờ, các mạng IPv4 đang có thể thấy và liên kết với nhau.

Cách 2: Tạo interface tunnel 0 trên Thename cùng Thename1 

- Thename

Câu lệnh:

Thename(config)#ipv6 unicast-routing

Thename(config)#interface tunnel 0

Thename(config-if)#ipv6 address 3000::1/64 eui-64

Thename(config-if)#no ipv6 nd suppress-ra

Thename(config-if)#tunnel source loopbachồng 0

Thename(config-if)#tunnel mode ipv6ip isatap

Để kiểm soát Tunnel vừa tạo ra, các bạn dùng lệnh show ipv6 interface brief.

*

Theo hình trên, Thename tất cả địa chỉ IPv6 của tunnel 0 là 3000::5EFE:101:101

- Thename1:

Cú pháp câu lệnh nhỏng sau:

Thename1(Config)#interface tunnel 0

Thename1(Config-if)#ipv6 enable

Thename1(Config-if)#ipv6 address autoconfig

Thename1(Config-if)#tunnel mode ipv6ip

Thename1(Config-if)#tunnel source fastethernet 0/0

Thename1(Config-if)#tunnel destination 1.1.1.1

Để bình chọn tunnel 0 vừa sinh sản, bạn cũng triển khai câu lệnh tương tự như nlỗi bên trên là cần sử dụng lệnh show ipv6 interface brief.

*

Theo bảng trên, cửa hàng IPv6 của tunnel0 trên Thenamemột là 3000::C0A8:1703

Bước 3: Thực hiện nay định đường tĩnh trên các router IPv6 để các mạng con thấy nhau, bằng cách cần sử dụng câu lệnh ipv6 route x:x:x:x::x/ next-hop hoặc interface.

- Thename: Thename(config)#ipv6 route 4000::/64 3000::c0a8:1703

- Thename1: Thename1(config)#ipv6 route 2000::/64 3000::5efe:101:101

Sau kia, các bạn khám nghiệm các bảng định đường.

Hình sau là bảng định con đường IPv6 bên trên Thename.

*

Dưới đó là bảng định con đường IPv6 bên trên Thename1.

*

Bước 4: Thực hiện nay setup IPv6 cho những host cùng ping nhằm soát sổ kết nối

Cách triển khai nhỏng sau:

- Đặt IPv6 đến laptop thực hiện Window Vista, 7, 8, 10, chúng ta thực hiện nlỗi chỉ dẫn biện pháp đặt tương tác IPv6 ngơi nghỉ mục bên trên. Đó là vào Start / lựa chọn Control panel / lựa chọn tiếp Network và Internet / click chọn Network and Sharing Center /cliông chồng mục Change adapter setting / với chọn Properties Local Area Connection / tiếp nối, cliông chồng vào Internet Protocol Version 6 để cài đặt liên hệ IPv6.

Đặt IPv6 đến máy tính xách tay thực hiện Window XP: Click vào nút Start / gõ Cmd trong thanh tìm tìm / kích hoạt chức năng IPv6 bằng cách gõ câu lệnh “netsh interface ipv6 install”. Sau đó, cần sử dụng tiếp lệnh “netsh interface ipv6 add address “Local Area Connection” 2000::2/64” để đặt địa chỉ IPv6.
*

Sau lúc hoàn chỉnh đặt thúc đẩy IPv6 đến host, chúng ta triển khai ping để soát sổ kết nối:

- Kiểm tra kết nối từ bỏ host 1 mang đến host 2

*

- Kiểm tra liên kết chiều ngược trở lại tự host 2 cho 1

*

Lúc bấy giờ, 2 host đang thấy nhau. Đây là hướng dẫn về phong thái cần sử dụng cách thức ISATAP.. thiết lập liên kết của IPv6 là gì. Mô hình mạng này tương đối đơn giản và dễ dàng với bạn thuận lợi không ngừng mở rộng với nhiều router khác nhau, phối hợp áp dụng định con đường cao cấp rộng.

Trong khi, các bạn cũng phải chú ý là trước khi dùng ping nhằm đánh giá kết nối, các bạn yêu cầu đảm bảo Window Firewall đã được tắt.